| # Copyright 2020 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75" |
| CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "5b20850cb32f8fc1646e154b9c6c5b094e5b5961" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb") |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk shill/cli .gn" |
| |
| PLATFORM_SUBDIR="shill/cli" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Shill Command Line Interface" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/shill/cli" |
| |
| LICENSE="BSD-Google" |
| SLOT="0/0" |
| KEYWORDS="*" |
| IUSE="" |
| |
| RDEPEND=" |
| >=chromeos-base/shill-0.0.1-r2205 |
| " |
| |
| DEPEND=" |
| chromeos-base/shill-client:= |
| chromeos-base/system_api:= |
| " |
| |
| src_install() { |
| dobin "${OUT}"/shillcli |
| } |
| |
| platform_pkg_test() { |
| platform_test "run" "${OUT}/shillcli_test" |
| } |