blob: 5e9b2244b552f8e58cc841c753d372509ae4b4f0 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("e0bda9124d13e798932c5d4f1c50fdd5fb14a888" "4527403fcdf7416eae625fa39718b6c8f9842987")
CROS_WORKON_TREE=("64c996c8f82d5e2aebfb468fe16f8e663fc1ea52" "7c60117e575ed6b6cc1bf3e5c39ca9b1577253a4")
CROS_WORKON_PROJECT=(
"chromiumos/platform/tast-tests"
"chromiumos/platform/tast"
)
CROS_WORKON_LOCALNAME=(
"platform/tast-tests"
"platform/tast"
)
CROS_WORKON_DESTDIR=(
"${S}"
"${S}/tast-base"
)
CROS_GO_WORKSPACE=(
"${CROS_WORKON_DESTDIR[@]}"
)
CROS_GO_TEST=(
# Also test support packages that live above local/bundles/.
"chromiumos/tast/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
inherit cros-workon tast-bundle
DESCRIPTION="Bundle of local integration tests for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests/"
LICENSE="Apache-2.0 BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE="arc chromeless_tty chromeless_tests cups"
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND="
chromeos-base/policy-testserver
chromeos-base/tast-local-helpers-cros
chromeos-base/virtual-usb-printer
chromeos-base/wprgo
!chromeless_tty? (
!chromeless_tests? (
chromeos-base/drm-tests
)
)
dev-libs/openssl:0=
arc? (
chromeos-base/tast-local-apks-cros
dev-util/android-tools
dev-util/android-uiautomator-server
)
net-misc/curl
cups? (
net-print/ippsample
)
sys-apps/memtester
sys-apps/rootdev
virtual/udev
"