blob: 6e190894b592d48b8b0f672820579d36af32f1c2 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "4be8d3ae5664634825afc2e6e4b8c24816ee9b9e" "318ca9f48604274cd31481e13eb9321be3d94d8f" "f4e43ea494df44704ba2c63dc081d63a689e6a41" "fcb83ee936c01758d591bb6f7a7734f054dd30ae" "60fa47aebd6ebfb702012849bd560717fceddcd4")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/tools/connector_client camera/common camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/tools/connector_client"
inherit cros-camera cros-workon platform
DESCRIPTION="A simple package that exercises cros-camera-libcamera_connector"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="chromeos-base/cros-camera-libs"
DEPEND="${RDEPEND}
x11-libs/libdrm"
BDEPEND="virtual/pkgconfig"
src_install() {
platform_src_install
dobin "${OUT}/cros_camera_connector_client"
}