blob: b9d7d3d3b3e786a8eb91ac1d05af30747626f26c [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "4be8d3ae5664634825afc2e6e4b8c24816ee9b9e" "2de57cadefcee72268944188060875f71560d058" "fcb83ee936c01758d591bb6f7a7734f054dd30ae" "60fa47aebd6ebfb702012849bd560717fceddcd4")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/tools camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/tools/cros_camera_tool"
inherit cros-camera cros-workon platform
DESCRIPTION="Chrome OS camera test utility."
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="chromeos-base/cros-camera-libs:="
BDEPEND="virtual/pkgconfig"
src_install() {
platform_src_install
dobin "${OUT}/cros-camera-tool"
}