blob: 7b242a57cf37b3ba9979bb4457c32a6e3c319f1a [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME=("../platform/dev")
CROS_WORKON_SUBTREE="src/chromiumos/test/publish"
inherit cros-go cros-workon
DESCRIPTION="Publish server implementation for uploading test result artifacts to GCS bucket"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/dev-util/+/HEAD/src/chromiumos/test/publish"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
CROS_GO_WORKSPACE=(
"${S}"
)
CROS_GO_BINARIES=(
"chromiumos/test/publish/cmd/cros-publish"
)
CROS_GO_TEST=(
"chromiumos/test/publish/cmd/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
DEPEND="
dev-util/lro-server
dev-go/crypto
dev-go/gcp-storage
dev-go/grpc
dev-go/mock
dev-go/protobuf
chromeos-base/cros-config-api
"
RDEPEND="${DEPEND}"