| # Copyright 2014 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT="db3923aa9569c82277f8756af3ba1c2f2b049330" |
| CROS_WORKON_TREE="a96a7377abfe6ed34ede08a29f37699b83e55684" |
| CROS_WORKON_PROJECT="chromiumos/platform/frecon" |
| CROS_WORKON_LOCALNAME="../platform/frecon" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| |
| inherit cros-sanitizers cros-workon cros-common.mk |
| |
| DESCRIPTION="Chrome OS KMS console (without DBUS/UDEV support)" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/frecon" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="*" |
| IUSE="-asan" |
| |
| BDEPEND="virtual/pkgconfig" |
| |
| COMMON_DEPEND="media-libs/libpng:0= |
| sys-apps/libtsm:=" |
| |
| RDEPEND="${COMMON_DEPEND}" |
| |
| DEPEND="${COMMON_DEPEND} |
| media-sound/adhd:= |
| x11-libs/libdrm:=" |
| |
| src_configure() { |
| export FRECON_LITE=1 |
| sanitizers-setup-env |
| cros-common.mk_src_configure |
| } |