blob: 9b4d2451543a578edfff3faa5c05a4bd0d67c7ff [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="909f58cf6010e11d37caad4e3e1de69c4064b251"
CROS_WORKON_TREE="673c2aba9ae1ce95a46c49852fff7f59511841e5"
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon autotest-deponly
DESCRIPTION="Autotest D-Bus deps"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
# Autotest enabled by default.
IUSE="+autotest"
AUTOTEST_DEPS_LIST="dbus_protos"
# NOTE: For deps, we need to keep *.a
AUTOTEST_FILE_MASK="*.tar.bz2 *.tbz2 *.tgz *.tar.gz"
DEPEND="chromeos-base/system_api
dev-libs/protobuf:=
"
# Calling this here, so tests using this dep don't have to call setup_dep().
src_prepare() {
autotest-deponly_src_prepare
}