blob: 231196a82eaf276033b5d4aad3bba41fd91cd8bb [file] [log] [blame]
#
# Copyright 2023 Google LLC
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# version 2 as published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Intel Synchronous Ethernet (SyncE) implementation"
HOMEPAGE="https://github.com/intel/synce4l"
SRC_URI="gs://chromeos-localmirror/distfiles/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="*"
IUSE=""
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
emake CC="$(tc-getCC)" DESTDIR="${ED}" prefix=/usr mandir=/usr/local install
}