blob: 5ff3a5ccc8a5ccf0db5e856fba5129752a87d3d6 [file] [log] [blame]
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit eutils golang-base
EGO_PN="github.com/docker/libnetwork"
if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
EGIT_COMMIT="e7933d41e7b206756115aa9df5e0599fc5169742"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="*"
inherit golang-vcs-snapshot
fi
DESCRIPTION="Docker container networking"
HOMEPAGE="https://github.com/docker/libnetwork"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
S=${WORKDIR}/${P}/src/${EGO_PN}
RESTRICT="test" # needs dockerd
src_compile() {
export GOTRACEBACK="crash"
GO=$(tc-getGO)
export GO
GOPATH="${WORKDIR}/${P}" ${GO} build -o "bin/docker-proxy" ./cmd/proxy || die
}
src_install() {
dodoc ROADMAP.md README.md CHANGELOG.md
dobin bin/docker-proxy
}