blob: db7ee6dd42773651d39e0d25f9ce7d80c4538c70 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="485132dcca3b34717eb1bf3aa9ffeaf4bc4286c9"
CROS_WORKON_TREE="81a8168951f0208b6cbde58c775933c3a933c1bb"
CROS_WORKON_PROJECT="chromiumos/third_party/coreboot"
CROS_WORKON_LOCALNAME="coreboot"
inherit cros-board cros-workon cros-coreboot
KEYWORDS="arm"
DEPEND="sys-boot/exynos-pre-boot"
RDEPEND="!sys-boot/chromeos-coreboot"
src_prepare() {
# src is installed by "exynos-pre-boot".
local src="${SYSROOT}/firmware/u-boot.bl1.bin"
# dest is required by Makefile.inc in coreboot source tree.
local dest="3rdparty/cpu/samsung/exynos5250/bl1.bin"
mkdir -p "$(dirname "${dest}")"
cp -pf "${src}" "${dest}" || die
}