blob: a9d19f693aa9904266f97516d24f7c41d98d22b7 [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=5
DESCRIPTION="CoreOS Toolbox Utility"
HOMEPAGE="https://github.com/coreos/toolbox"
EGIT_REPO_URI="https://cos.googlesource.com/third_party/toolbox.git"
EGIT_COMMIT="c9efb0c1d5a96383bf4037309fc0dda914a28b39"
EGIT_MASTER="main"
inherit eutils git-2 systemd
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND} app-misc/jq"
src_install() {
dobin "${S}"/toolbox
systemd_dounit "${FILESDIR}"/var-lib-toolbox.mount
systemd_dounit "${FILESDIR}"/var-lib-toolbox-remount.service
systemd_enable_service local-fs.target var-lib-toolbox.mount
}