blob: 319d02a98efdcb1ba7aab112c1768f31793592ba [file] [log] [blame]
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
EGO_PN="github.com/docker/libnetwork"
if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
EGIT_COMMIT="3eb39382bfa6a3c42f83674ab080ae13b0e34e5d"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="*"
inherit golang-vcs-snapshot
fi
DESCRIPTION="Docker container networking"
HOMEPAGE="https://github.com/docker/libnetwork"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
S=${WORKDIR}/${P}/src/${EGO_PN}
RESTRICT="test" # needs dockerd
src_compile() {
GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
}
src_install() {
dodoc README.md CHANGELOG.md
dobin bin/docker-proxy
}