blob: 358dc9c76f22a12675c2eabcc057b65a4d6a4830 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="972c83a82a78b427d79e941c3490a819069ef4d4"
CROS_WORKON_TREE="02b7314d36eae30ac623b14e82492b44ceae8285"
CROS_WORKON_PROJECT="chromiumos/third_party/coreboot"
CROS_WORKON_LOCALNAME="coreboot"
inherit cros-board cros-workon cros-coreboot
KEYWORDS="arm"
DEPEND="sys-boot/exynos-pre-boot"
RDEPEND="!sys-boot/chromeos-coreboot"
src_prepare() {
# src is installed by "exynos-pre-boot".
local src="${SYSROOT}/firmware/u-boot.bl1.bin"
# dest is required by Makefile.inc in coreboot source tree.
local dest="3rdparty/cpu/samsung/exynos5250/bl1.bin"
mkdir -p "$(dirname "${dest}")"
cp -pf "${src}" "${dest}" || die
}