blob: 279478543197eb7966c19551cf41d848b4cb1a0b [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
CROS_WORKON_COMMIT="34e70930e74d939cc11bd022fa323e82110be3f3"
CROS_WORKON_TREE="404f967ddaa26452bb0c72fb84bb5ccc961a258c"
CROS_WORKON_PROJECT="chromiumos/third_party/coreboot"
CROS_WORKON_LOCALNAME="coreboot"
inherit cros-board cros-workon cros-coreboot
KEYWORDS="arm"
DEPEND="sys-boot/exynos-pre-boot"
RDEPEND="!sys-boot/chromeos-coreboot"
src_prepare() {
# src is installed by "exynos-pre-boot".
local src="${SYSROOT}/firmware/u-boot.bl1.bin"
# dest is required by Makefile.inc in coreboot source tree.
local dest="3rdparty/cpu/samsung/exynos5250/bl1.bin"
mkdir -p "$(dirname "${dest}")"
cp -pf "${src}" "${dest}" || die
}