| # Copyright 1999-2020 Gentoo Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=6 |
| |
| PYTHON_COMPAT=( python{3_6,3_7,3_8} ) |
| |
| inherit distutils-r1 |
| |
| DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic" |
| HOMEPAGE="https://github.com/idan/oauthlib https://pypi.org/project/oauthlib/" |
| SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz" |
| |
| LICENSE="BSD" |
| SLOT="0" |
| KEYWORDS="*" |
| IUSE="test" |
| RESTRICT="!test? ( test )" |
| |
| # optional extras hard set as RDEPs. See setup.py |
| RDEPEND=" |
| >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}] |
| dev-python/blinker[${PYTHON_USEDEP}] |
| dev-python/cryptography[${PYTHON_USEDEP}] |
| " |
| DEPEND=" |
| dev-python/setuptools[${PYTHON_USEDEP}] |
| test? ( ${RDEPEND} |
| dev-python/nose[${PYTHON_USEDEP}] |
| $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7) |
| $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' python2_7) ) |
| " |
| |
| python_test() { |
| nosetests -v || die "tests failed under ${EPYTHON}" |
| } |