blob: b581e1b9621e095a21860f785b2ae22400be76b0 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# This ebuild only cares about its own FILESDIR and ebuild file, so it tracks
# the canonical empty project.
CROS_WORKON_COMMIT="3a01873e59ec25ecb10d1b07ff9816e69f3bbfee"
CROS_WORKON_TREE="8ce164efd78fcb4a68e898d8c92c7579657a49b1"
CROS_WORKON_PROJECT="chromiumos/infra/build/empty-project"
CROS_WORKON_LOCALNAME="empty-project"
inherit appid cros-unibuild cros-workon
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
KEYWORDS="-* amd64 x86"
# Add dependencies on other ebuilds from within this board overlay
RDEPEND="
chromeos-base/sof-binary:=
chromeos-base/sof-topology:=
"
DEPEND="
${RDEPEND}
chromeos-base/chromeos-config:=
"
src_install() {
doappid "{2514829E-8550-4E24-91F2-331AB7A12B03}" "CHROMEBOX"
unibuild_install_audio_files
}