blob: f76479ffe9dafc607e8c4eab4d7d7ae8a3ba80aa [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
inherit systemd
DESCRIPTION="Alphabet compliance scripts"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
sys-apps/systemd
net-firewall/iptables
sys-auth/pambase
sys-libs/pam[audit]
sys-process/audit
"
S="${WORKDIR}"
src_install() {
exeinto /usr/share/google/security
doexe "${FILESDIR}"/*.sh
systemd_dounit "${FILESDIR}"/cos-alphabet-compliance.service
systemd_enable_service multi-user.target cos-alphabet-compliance.service
}