blob: a5b572cf7ee9542a1d2ba4a200437c0ff3a55650 [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit appid cros-audio-configs
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE=""
S="${WORKDIR}"
# Add dependencies on other ebuilds from within this board overlay
RDEPEND="
chromeos-base/chromeos-bsp-baseboard-strago
chromeos-base/ec-utils
sys-kernel/linux-firmware
chromeos-base/chromeos-touch-config-celes
"
DEPEND="${RDEPEND}"
src_install() {
doappid "{7834CC99-3294-421F-9963-028D7D6512CA}" "CHROMEBOOK"
# Install platform specific config files for power_manager.
insinto "/usr/share/power_manager/board_specific"
doins "${FILESDIR}"/powerd_prefs/*
# Wiping scripts.
dosbin "${FILESDIR}"/*.sh
# Install Bluetooth ID override.
insinto "/etc/bluetooth"
doins "${FILESDIR}/main.conf"
# Install audio configs.
local audio_config_dir="${FILESDIR}/audio-config"
install_audio_configs celes "${audio_config_dir}"
}