blob: 9526bf10ba6865a112888395acaa7b4681b95c7c [file] [log] [blame]
#
# Copyright 2021 Google LLC
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# version 2 as published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
EAPI=7
DESCRIPTION="Alphabet compliance scripts"
CROS_WORKON_MANUAL_UPREV="1"
CROS_WORKON_COMMIT="d35cf650e254a8c906dc4d5e5a495cd155669a67"
CROS_WORKON_TREE="badeb94b1441ece42748cb2f92e4476670461b29"
CROS_WORKON_REPO="https://cos.googlesource.com"
CROS_WORKON_PROJECT="cos/compliance"
CROS_WORKON_LOCALNAME="../compliance"
inherit systemd cros-workon
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
sys-apps/systemd
net-firewall/iptables
sys-auth/pambase
sys-libs/pam[audit]
sys-process/audit
"
src_install() {
ebegin "Installing alphabet-compliance scripts"
SCRIPTS=/usr/share/google/security/experimental/alphabet-compliance/scripts
exeinto ${SCRIPTS}
doexe "${FILESDIR}"/configure.sh
# install scripts and readme from cos/compliance repo
doexe ${CROS_WORKON_DESTDIR}/alphabet-compliance/scripts/*.sh
insinto ${SCRIPTS}
doins ${CROS_WORKON_DESTDIR}/README.md
systemd_dounit "${FILESDIR}"/cos-alphabet-compliance.service
systemd_enable_service multi-user.target cos-alphabet-compliance.service
}