awscli: upgraded package to upstream

Upgraded dev-python/awscli to version 1.18.142 on amd64

I needed to set the upper bound of PYTHON_COMPAT to python3_8, because
python3_9 is not understood by the m85 build system.

BUG=b/172694825
TEST=emerge-arion awscli
RELEASE_NOTE=None

cos-patch: bug
Change-Id: Ic6f0e141df8f7d31ccf45980d07a8e70b586398b
Reviewed-on: https://cos-review.googlesource.com/c/third_party/overlays/portage-stable/+/8404
Tested-by: Robert Kolchmeyer <rkolchmeyer@google.com>
Reviewed-by: Roy Yang <royyang@google.com>
(cherry picked from commit d035a4a6e62b0a26c3c7ce24b383a644a2aca5a7)
Reviewed-on: https://cos-review.googlesource.com/c/third_party/overlays/portage-stable/+/9067
Tested-by: Cusky Presubmit Bot <presubmit@cos-infra-prod.iam.gserviceaccount.com>
Main-Branch-Verified: Cusky Presubmit Bot <presubmit@cos-infra-prod.iam.gserviceaccount.com>
4 files changed