libgcrypt: upgraded package to upstream

Upgraded dev-libs/libgcrypt to version 1.9.3 on amd64, arm64

BUG=b/191344862
TEST=presubmit
RELEASE_NOTE=Upgraded libgcrypt to 1.9.3. This fixes
CVE-2021-33560.

cos-patch: lts-refresh
Change-Id: I93841c732636c12df39c44e786fbaa5f7f73dfb8
Reviewed-on: https://cos-review.googlesource.com/c/third_party/overlays/portage-stable/+/18171
Tested-by: Cusky Presubmit Bot <presubmit@cos-infra-prod.iam.gserviceaccount.com>
Main-Branch-Verified: Cusky Presubmit Bot <presubmit@cos-infra-prod.iam.gserviceaccount.com>
Reviewed-by: Roy Yang <royyang@google.com>
5 files changed