blob: de6afce3a868838a1e1644c30f5b05f74654b77e [file] [log] [blame]
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit flag-o-matic toolchain-funcs
DESCRIPTION="Super-useful stream editor"
HOMEPAGE="http://sed.sourceforge.net/"
SRC_URI="mirror://gnu/sed/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="*"
IUSE="acl nls selinux static"
RDEPEND="
!static? (
acl? ( virtual/acl )
nls? ( virtual/libintl )
selinux? ( sys-libs/libselinux )
)
"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
static? (
acl? ( virtual/acl[static-libs(+)] )
nls? ( virtual/libintl[static-libs(+)] )
selinux? ( sys-libs/libselinux[static-libs(+)] )
)
"
src_configure() {
local myconf=()
if use userland_GNU; then
myconf+=( --exec-prefix="${EPREFIX}" )
else
myconf+=( --program-prefix=g )
fi
export ac_cv_search_setfilecon=$(usex selinux -lselinux)
export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
use static && append-ldflags -static
myconf+=(
$(use_enable acl)
$(use_enable nls)
)
econf "${myconf[@]}"
}