blob: f2d3e2772290379af40c6a90aa83b34220e7dbb2 [file] [log] [blame]
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
inherit distutils-r1
DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
HOMEPAGE="https://github.com/tych0/xcffib"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
IUSE="test"
COMMON_DEPEND="x11-libs/libxcb"
RDEPEND="
$(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
$(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
dev-python/six[${PYTHON_USEDEP}]
${COMMON_DEPEND}"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
${COMMON_DEPEND}
test? (
dev-python/nose[${PYTHON_USEDEP}]
x11-apps/xeyes
)"
PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
python_test() {
nosetests -d -v || die
}