blob: 06c1b184a465e4ea22fbb8bd1aca2e70240a0a6e [file] [log] [blame]
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1
DESCRIPTION="Sphinx extension which outputs outputs serialized HTML files"
HOMEPAGE="http://www.sphinx-doc.org"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="*"
RDEPEND=""
PDEPEND="
>=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]"
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die
}