blob: ef16f353bf6453fccf4c25d3bc453c9e658dfb6f [file] [log] [blame]
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
inherit python-r1
DESCRIPTION="Namespace package declaration for sphinxcontrib"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages"
SRC_URI=""
LICENSE="public-domain"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${PYTHON_DEPS}"
DEPEND="${PYTHON_DEPS}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
MODNAME=${PN#namespace-}
src_unpack() {
mkdir -p "${S}"/${MODNAME} || die
cat > "${S}"/${MODNAME}/__init__.py <<-EOF || die
__import__('pkg_resources').declare_namespace(__name__)
EOF
}
src_install() {
python_foreach_impl python_domodule ${MODNAME}
}