blob: 4a4171294cf30814f8fa75f72e52abcf4f1c61ab [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
MY_P="${P}-20050316"
DESCRIPTION="A light-weight XML object model for Python"
HOMEPAGE="http://effbot.org/zone/element-index.htm https://pypi.org/project/elementtree/"
SRC_URI="http://effbot.org/downloads/${MY_P}.tar.gz"
LICENSE="ElementTree"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
python_prepare_all() {
sed -e "s/distutils.core/setuptools/" -i setup.py || die "sed failed"
distutils-r1_python_prepare_all
}
python_test() {
"${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
}
python_install_all() {
local HTML_DOCS=( docs/. )
distutils-r1_python_install_all
}