blob: f4e9f3e783d26f847851eadc4d6fed81e174c335 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.0.1-r1.ebuild,v 1.2 2014/07/06 13:18:50 mgorny Exp $
EAPI=5
# Kids, don't do this at home!
inherit python-utils-r1
PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
inherit autotools-utils python-r1
DESCRIPTION="Python script wrapper"
HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD-2"
SLOT="2"
KEYWORDS="*"
IUSE=""
RDEPEND="!<dev-python/python-exec-10000"
src_configure() {
local pyimpls i EPYTHON
for i in "${PYTHON_COMPAT[@]}"; do
python_export "${i}" EPYTHON
pyimpls+=" ${EPYTHON}"
done
export EPYTHON='python2.7'
local myeconfargs=(
--with-eprefix="${EPREFIX}"
--with-python-impls="${pyimpls}"
)
autotools-utils_src_configure
}