| # Copyright 1999-2021 Gentoo Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| DESCRIPTION="Excellent text file viewer" |
| HOMEPAGE="http://www.greenwoodsoftware.com/less/" |
| SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz" |
| |
| LICENSE="|| ( GPL-3 BSD-2 )" |
| SLOT="0" |
| KEYWORDS="*" |
| IUSE="pcre unicode" |
| |
| DEPEND=">=app-misc/editor-wrapper-3 |
| >=sys-libs/ncurses-5.2:0= |
| pcre? ( dev-libs/libpcre2 )" |
| RDEPEND="${DEPEND}" |
| |
| src_configure() { |
| export ac_cv_lib_ncursesw_initscr=$(usex unicode) |
| export ac_cv_lib_ncurses_initscr=$(usex !unicode) |
| local myeconfargs=( |
| --with-regex=$(usex pcre pcre2 posix) |
| --with-editor="${EPREFIX}"/usr/libexec/editor |
| ) |
| econf "${myeconfargs[@]}" |
| } |
| |
| src_install() { |
| default |
| |
| newbin "${FILESDIR}"/lesspipe-r1.sh lesspipe |
| newenvd "${FILESDIR}"/less.envd 70less |
| } |
| |
| pkg_preinst() { |
| if has_version "<${CATEGORY}/${PN}-483-r1" ; then |
| elog "The lesspipe.sh symlink has been dropped. If you are still setting" |
| elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'." |
| elog "Colorization support has been dropped. If you want that, check out" |
| elog "the new app-text/lesspipe package." |
| fi |
| } |