blob: 75a28b859da343ac2a9188b8195c93b6a3d5f43a [file] [log] [blame]
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="A simple, small, efficient, C++ XML parser"
HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0/8"
KEYWORDS="*"
IUSE="test"
RESTRICT="!test? ( test )"
multilib_src_configure() {
local mycmakeargs=( -DBUILD_TESTING=$(usex test) )
cmake_src_configure
}