blob: a105c4014ff792c807f4144e43f7173781eb1fde [file] [log] [blame]
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit multilib-minimal libtool
DESCRIPTION="ASN.1 library"
HOMEPAGE="https://www.gnu.org/software/libtasn1/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3 LGPL-2.1"
SLOT="0/6" # subslot = libtasn1 soname version
KEYWORDS="*"
IUSE="doc static-libs test valgrind"
BDEPEND="sys-apps/help2man
virtual/yacc
test? ( valgrind? ( dev-util/valgrind ) )"
DOCS=(
AUTHORS
ChangeLog
NEWS
README
THANKS
)
pkg_setup() {
if use doc; then
DOCS+=( doc/libtasn1.pdf )
HTML_DOCS=( doc/reference/html/. )
fi
}
src_prepare() {
default
elibtoolize # for Solaris shared library
}
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable static-libs static) \
$(multilib_native_use_enable valgrind valgrind-tests)
}
multilib_src_install_all() {
einstalldocs
find "${D}" -name '*.la' -delete || die
}