blob: dd178c5456ebc77d7381f175f482d6a59d0f550f [file] [log] [blame]
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1
MY_PN=${PN/-/_}
MY_P=${MY_PN}-${PV}
DESCRIPTION="Type Hint extensions from Python 3.7 backported to 3.5/3.6"
HOMEPAGE="https://pypi.org/project/typing_extensions/ https://github.com/python/typing"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}
LICENSE="PSF-2"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
python_test() {
cd "${S}"/src_py3 || die
"${EPYTHON}" test_typing_extensions.py -v || die "tests failed under ${EPYTHON}"
}