blob: 7826252479695a081c9188f1d9bc386557763a50 [file] [log] [blame]
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
inherit distutils-r1
DESCRIPTION="Python 2 and 3 compatibility library"
HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
IUSE="doc test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx )
test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
python_compile_all() {
use doc && emake -C documentation html
}
python_test() {
pytest -vv || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
use doc && local HTML_DOCS=( documentation/_build/html/. )
distutils-r1_python_install_all
}