blob: 73e405c0f7735deee5dc7f518e79b5af40a903d6 [file] [log] [blame]
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit flag-o-matic toolchain-funcs
DESCRIPTION="Utility to trace the route of IP packets"
HOMEPAGE="http://traceroute.sourceforge.net/"
SRC_URI="mirror://sourceforge/traceroute/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="*"
IUSE="static"
RDEPEND="!<net-misc/iputils-20121221-r1
!net-misc/iputils[traceroute]"
src_compile() {
use static && append-ldflags -static
append-ldflags -L../libsupp #432116
tc-export AR CC RANLIB
emake env=yes
}
src_install() {
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
dodoc ChangeLog CREDITS README TODO
dosym traceroute /usr/bin/traceroute6
dosym traceroute.8 /usr/share/man/man8/traceroute6.8
}