blob: 4b428fec6a51f3cb083ce300f2e18a8855f92f3e [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="Python 3.4 Enum backported"
HOMEPAGE="https://pypi.python.org/pypi/enum34"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="*"
IUSE="doc"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
"${PYTHON}" enum/test.py || die "Tests failed under ${EPYTHON}"
}
python_install_all() {
use doc && local DOCS=( enum/doc/. enum/README )
distutils-r1_python_install_all
}