blob: f179d465e11df72fb1dafd1acdb7bdeb600972b3 [file] [log] [blame]
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
inherit distutils-r1
DESCRIPTION="Attributes without boilerplate"
HOMEPAGE="
https://github.com/hynek/attrs
https://attrs.readthedocs.org/
https://pypi.org/project/attrs/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
IUSE="test"
RDEPEND="
dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
$(python_gen_impl_dep sqlite)
>=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)"
python_test() {
py.test -v || die "tests failed with ${EPYTHON}"
}