blob: 59766765e15f584a2d6e8b1046c481c3240747bf [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/sharutils-4.14-r1.ebuild,v 1.10 2014/08/12 12:19:31 vapier Exp $
EAPI="5"
inherit eutils
MY_P="${P/_/-}"
DESCRIPTION="Tools to deal with shar archives"
HOMEPAGE="http://www.gnu.org/software/sharutils/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="*"
IUSE="nls"
DEPEND="app-arch/xz-utils
sys-apps/texinfo
nls? ( >=sys-devel/gettext-0.10.35 )"
S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}"/${PN}-4.14-popen-rb.patch
}
src_configure() {
strip-linguas -u po
econf $(use_enable nls)
}