blob: 63e5505747a7dde479afcaed2e9aeb6222f354f5 [file] [log] [blame]
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit python-r1 toolchain-funcs
DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
HOMEPAGE="http://yasm.tortall.net/"
SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
SLOT="0"
KEYWORDS="*"
IUSE="nls python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
nls? ( virtual/libintl )
python? ( ${PYTHON_DEPS} )"
DEPEND="
${RDEPEND}
nls? ( sys-devel/gettext )
python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
src_configure() {
use python && python_export_best
XMLTO=: \
econf \
CC_FOR_BUILD=$(tc-getBUILD_CC) \
CCLD_FOR_BUILD=$(tc-getBUILD_CC) \
$(use_enable python) \
$(use_enable python python-bindings) \
$(use_enable nls)
}
src_test() {
emake check
}