blob: a1f618a6a63c1fdef8a5be6f9399828bd36004a4 [file] [log] [blame]
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{5,6,7})
inherit distutils-r1
DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
HOMEPAGE="https://github.com/pyca/pynacl/ https://pypi.org/project/PyNaCl/"
SRC_URI="https://github.com/pyca/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="*"
IUSE="test"
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
>=dev-python/cffi-1.4.1[${PYTHON_USEDEP}]
dev-libs/libsodium:0/23
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( >=dev-python/hypothesis-3.27.0[${PYTHON_USEDEP}]
>=dev-python/pytest-3.2.1[${PYTHON_USEDEP}] )
"
src_prepare() {
# For not using the bundled libsodium
export SODIUM_INSTALL=system
distutils-r1_python_prepare_all
}
python_test() {
py.test -v || die "Tests failed under ${EPYTHON}"
}