blob: d2093c5f9b8ebfb3a61a5facffaabc7d8e74e3e8 [file] [log] [blame]
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
inherit distutils-r1
DESCRIPTION="A small 'shelve' like datastore with concurrency support"
HOMEPAGE="https://github.com/pickleshare/pickleshare"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="*"
IUSE="test"
RDEPEND="
$(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' 'python2*')
>=dev-python/path-py-6.2[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
RESTRICT="test"
python_test() {
py.test || die
}