blob: a845c846d42cd742f746950d3e958092238c4b91 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.8a.ebuild,v 1.10 2015/01/22 13:01:32 ulm Exp $
EAPI=4
inherit autotools elisp-common eutils toolchain-funcs
DESCRIPTION="Interactively examine a C program"
HOMEPAGE="http://cscope.sourceforge.net/"
SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
LICENSE="BSD GPL-2+"
SLOT="0"
KEYWORDS="*"
IUSE="emacs"
RDEPEND=">=sys-libs/ncurses-5.2
emacs? ( virtual/emacs )"
DEPEND="${RDEPEND}
sys-devel/flex
virtual/pkgconfig
virtual/yacc"
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
epatch "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
eautoreconf # prevent maintainer mode later on
}
src_compile() {
emake CURSES_LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
if use emacs; then
cd "${S}"/contrib/xcscope || die
elisp-compile *.el
fi
}
src_install() {
default
if use emacs; then
cd "${S}"/contrib/xcscope || die
elisp-install ${PN} *.el *.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
dobin cscope-indexer
fi
cd "${S}"/contrib/webcscope || die
docinto webcscope
dodoc INSTALL TODO cgi-lib.pl cscope hilite.c
docinto webcscope/icons
dodoc icons/*.gif
}
pkg_postinst() {
use emacs && elisp-site-regen
}
pkg_postrm() {
use emacs && elisp-site-regen
}