blob: f3e27f6d5f967da195bda060fd5f38bab8d22cc9 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.13.2-r2.ebuild,v 1.10 2014/08/27 09:01:30 jer Exp $
EAPI=5
EGIT_REPO_URI="git://anongit.freedesktop.org/libreoffice/cppunit"
[[ ${PV} = 9999 ]] && inherit git-r3 autotools
inherit eutils flag-o-matic multilib-minimal
DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/cppunit"
[[ ${PV} = 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
[[ ${PV} = 9999 ]] || \
KEYWORDS="*"
IUSE="doc examples static-libs"
RDEPEND=""
DEPEND="${RDEPEND}
doc? (
app-doc/doxygen[dot]
media-gfx/graphviz
)"
DOCS=( AUTHORS BUGS NEWS README THANKS TODO doc/FAQ )
[[ ${PV} = 9999 ]] || DOCS+=( ChangeLog )
MULTILIB_CHOST_TOOLS=(
/usr/bin/cppunit-config
)
src_prepare() {
[[ ${PV} = 9999 ]] && eautoreconf
}
src_configure() {
# Anything else than -O0 breaks on alpha
use alpha && replace-flags "-O?" -O0
multilib-minimal_src_configure
}
multilib_src_configure() {
ECONF_SOURCE=${S} \
econf \
$(use_enable static-libs static) \
$(multilib_native_use_enable doc doxygen) \
$(multilib_native_use_enable doc dot) \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
--disable-silent-rules
}
multilib_src_install_all() {
einstalldocs
prune_libtool_files --all
if use examples ; then
find examples -iname "*.o" -delete
insinto /usr/share/${PN}
doins -r examples
fi
}