blob: e33f9db80d502228d031f4b2da4c1ad1b99b069f [file] [log] [blame]
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
CABAL_FEATURES="bin nocabaldep"
inherit eutils haskell-cabal
DESCRIPTION="Rebuild Haskell dependencies in Gentoo"
HOMEPAGE="https://wiki.haskell.org/Gentoo#haskell-updater"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND=">=dev-lang/ghc-6.12.1"
# Need a lower version for portage to get --keep-going
RDEPEND="|| ( >=sys-apps/portage-2.1.6
sys-apps/pkgcore )"
src_prepare() {
default
if use prefix; then
sed -i -e "s,/var/db/pkg,${EPREFIX}&,g" \
"${S}/Distribution/Gentoo/Packages.hs" || die
sed -i -e 's,"/","'"${EPREFIX}"'/",g' \
"${S}/Distribution/Gentoo/GHC.hs" || die
fi
}
src_configure() {
cabal_src_configure \
--bindir="${EPREFIX}/usr/sbin" \
--constraint="Cabal == $(cabal-version)"
}
src_install() {
cabal_src_install
dodoc TODO
}