| # Copyright 1999-2021 Gentoo Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| MY_PN=Vulkan-Headers |
| inherit cmake |
| |
| if [[ ${PV} == *9999* ]]; then |
| EGIT_REPO_URI="https://github.com/KhronosGroup/${MY_PN}.git" |
| inherit git-r3 |
| else |
| SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" |
| KEYWORDS="*" |
| S="${WORKDIR}"/${MY_PN}-${PV} |
| fi |
| |
| DESCRIPTION="Vulkan Header files and API registry" |
| HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers" |
| |
| LICENSE="Apache-2.0" |
| SLOT="0" |
| |
| BDEPEND=">=dev-util/cmake-3.10.2" |