blob: 12d71cc047657111db65db317ca935fd914de40e [file] [log] [blame]
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit cmake-utils
if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Headers.git"
inherit git-r3
else
EGIT_COMMIT="114c3546e195819bd53a34b39f5194b2989a5b12"
KEYWORDS="*"
SRC_URI="https://github.com/KhronosGroup/Vulkan-Headers/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/Vulkan-Headers-${EGIT_COMMIT}"
fi
DESCRIPTION="Vulkan Header files and API registry"
HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
LICENSE="Apache-2.0"
SLOT="0"
# Old packaging will cause file collisions
RDEPEND="!<=media-libs/vulkan-loader-1.1.70.0-r999"