blob: 99e871013695423c8e0357d8764dcba1b4a48787 [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
XORG_PACKAGE_NAME=libxfont
XORG_DOC=doc
inherit xorg-3
DESCRIPTION="X.Org Xfont library"
KEYWORDS="*"
IUSE="bzip2 ipv6 truetype"
RDEPEND="sys-libs/zlib
x11-base/xorg-proto
x11-libs/libfontenc
bzip2? ( app-arch/bzip2 )
truetype? ( >=media-libs/freetype-2 )"
DEPEND="${RDEPEND}
x11-base/xorg-proto
x11-libs/xtrans"
src_configure() {
local XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
$(use_enable doc devel-docs)
$(use_with doc xmlto)
$(use_with bzip2)
$(use_enable truetype freetype)
--without-fop
)
xorg-3_src_configure
}