blob: 85590f2b8f85532b3e1c3a543e87979d80a29705 [file] [log] [blame]
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
inherit distutils-r1
DESCRIPTION="Google Authentication Library"
HOMEPAGE="https://github.com/GoogleCloudPlatform/google-auth-library-python https://pypi.org/project/google-auth/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="*"
IUSE="test"
RDEPEND="
dev-python/namespace-google[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
>=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
>=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
>=dev-python/setuptools-40.3.0[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
dev-python/flask[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-localserver[${PYTHON_USEDEP}]
)"
python_test() {
# delete stray files included in the tarball
find "${S}"/tests -name '*.pyc' -delete || die
py.test || die "Tests failed under ${EPYTHON}"
}
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die
}