Upgrade dev-libs/glib and dev-util/glib-utils to 2.66.7

This addresses CVE-2021-27218 and CVE-2021-27219.

Upstreamed in parallel: crrev/c/2718437

BUG=b/181107685,b/181107526,b/181107515,b/181107276
TEST=presubmit
RELEASE_NOTE=Updated glib to v2.66.7. This addresses CVE-2021-27218
and CVE-2021-27219.

cos-patch: lts-refresh
Reviewed-on: https://cos-review.googlesource.com/c/third_party/overlays/chromiumos-overlay/+/13090
Reviewed-by: Vaibhav Rustagi <vaibhavrustagi@google.com>
Tested-by: Cusky Presubmit Bot <presubmit@cos-infra-prod.iam.gserviceaccount.com>
Change-Id: I0e028dde1f518c2d2ccd8e6b2e893ec2171a1a54
Reviewed-on: https://cos-review.googlesource.com/c/third_party/overlays/chromiumos-overlay/+/13191
Main-Branch-Verified: Cusky Presubmit Bot <presubmit@cos-infra-prod.iam.gserviceaccount.com>
5 files changed