dev-libs/openssl: Update openssl to 1.1.1o from upstream

BUG=b/232378973
TEST=presubmit
RELEASE_NOTE=Upgraded openssl to 1.1.1o to resolve CVE-2022-1292.

cos-patch: security-high
Change-Id: If6a09082c6a8d4808b231f10a3df43d6556c6452
Reviewed-on: https://cos-review.googlesource.com/c/third_party/overlays/chromiumos-overlay/+/32724
Reviewed-by: Robert Kolchmeyer <rkolchmeyer@google.com>
Main-Branch-Verified: Cusky Presubmit Bot <presubmit@cos-infra-prod.iam.gserviceaccount.com>
Tested-by: Cusky Presubmit Bot <presubmit@cos-infra-prod.iam.gserviceaccount.com>
4 files changed