blob: a6e99217d5dddc5a597305d507fb8098f494ec70 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/common camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/common/libcab_test"
inherit cros-camera cros-workon platform
DESCRIPTION="Test for camera algorithm bridge library"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="~*"
RDEPEND="
chromeos-base/cros-camera-libs
dev-cpp/gtest:="
DEPEND="${RDEPEND}"
src_install() {
dobin "${OUT}/libcab_test"
dolib.so "${OUT}/lib/libcam_algo_test.so"
}