blob: 27e725a4959235d642ab8c5c10df7019ab45e2b9 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
CROS_WORKON_COMMIT="ec8fc231e199b16c4d1a247853c9afc17d297402"
CROS_WORKON_TREE="7a0ac90ce1d88bf661f0dfc6ad457e10e87c6b96"
CROS_WORKON_PROJECT="chromiumos/platform/touchpad-tests"
CROS_WORKON_LOCALNAME="../platform/touchpad-tests"
inherit cros-workon cros-constants
DESCRIPTION="Chromium OS multitouch driver regression tests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/touchpad-tests"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="chromeos-base/gestures
chromeos-base/libevdev
app-misc/utouch-evemu
x11-base/xorg-proto"
DEPEND=${RDEPEND}
src_install() {
# install to autotest deps directory for dependency
emake DESTDIR="${D}${AUTOTEST_BASE}/client/deps/touchpad-tests" install
}